Back
Resolved

E-mails sent to @t-online.de are not delivered

Started 8 Mar at 10:38am CET.

portagon Go portagon Go API
Created

We're currently experiencing problems sending e-mails to @t-online.de addresses. All relevant parties are notified and already working on the problem.

Posted 8 Mar at 10:38am CET.